arduino IDE slow to start up - has anyone found turning off AntiVirus fixes it?

hi, have found that with Panda Cloud AntiVirus software running, the arduino IDE is extremely slow to start up and produces a 'Launch 4J' error message (though still does eventually run). the behaviour is almost identical to that reported with bluetooth devices present. this was running on a netbook under winXP.

has anyone else found that TURNING OFF ANTI-VIRUS SOFTWARE fixes problems with the arduino IDE?

cheers, rob :-)

Its not an ideal solution though is it? I can imagine loading all the libraries at start up is causing the AV software to do lots of redundant checking if its not optimized.

Since I'm on Ubuntu I never have such problems 8)

"Its not an ideal solution though is it?": one can argue that breathing is not an ideal solution, yet it is somewhat necessary if one wants to carry on living ;)

turning OFF my anti-virus software is the only solution i have found to allow the IDE to start up correctly. and the fact that it DOES work is indicative of where to investigate the underlying defect in the IDE's operation - assuming that a "launch 4J" error message is classified as a defect.

i am interested in seeing if turning OFF their anti-virus software solves startup delay issues for those using other anti-virus software (norton, AVG, etc), as the startup delays seem to be a widely encountered issue that the developers of the arduino IDE have largely relegated to the 'too hard' basket.

i am also using panda cloud antivirus on my laptop (old one, i use with the arduino software) and it's running ok .... maybe a little slow but it's running. the 'launch 4j' error appears from time to time when i try to load the arduino software with the laptop not fully booted (klicking too fast). i assume it is somewhat related to the enviromental setting (path to the jre not set properly at that point). so you should check your %path% variable.

any chance you could carry out a few experiments for me?

  1. using a stopwatch, time how long it takes between clicking the icon to launch the IDE and the edit window appearing with Panda AV running.
  2. repeat, but with Panda AVI disabled (right-click panda icon in system tray and select 'Stop antivirus')
  3. observe CPU usage during the above two tests, just using Windows Task manager to get a bit of an estimate is fine. If you can, perhaps try and see what process is using most CPU time.

cheers, rob :-)

with panda cloud av running: startup time 17 seconds with panda cloud av disabled: startup time 7 seconds

well i guess that is due to the slow cpu and low ram (256 mb ram)

cpu usage is approx. the same in both cases javaw (the arduino process) takes max 97% (2% for the taskmanager) as for processes associated with panda ... no real spike or something there.

btw: could it be that you enabled the "behavior analysis" option ? it takes quite a punch on performance ... especially with java

I use the free stuff here and have not noticed any delays in starting the IDE.

i'm running the free version of panda, so behavioural analysis is locked in the 'off' position. have also turned off behavioural blocking, but this produces no improvement. have also set the delay for cloud response down to the minimum (10 seconds)

BUT, have observed the following interesting thing: the panda process PSANHost.exe is generating around 1,700,000 (1.7 million) i/o reads while the arduino IDE is attempting to start up. if i turn panda off, then obviously it doesn't generate these reads, but they don't reappear anywhere else. the process javaw.exe generates less than 10,000 i/o reads irrespective of panda being on or off.

so, what can the arduino IDE be doing to generate this much i/o activity in a antivirus program??? i am wondering if it is an 'odd' behaviour of the arduino IDE - not necessarily a bug, but perhaps just something unexpected - exposing a bug that exists in panda (and potentially other antivirus software).

simple it uses java

java always triggers an immense response in av programs. i noticed that again and again.
i think it has something to do with classfile loading by the vm itself. on startup it reads a lot of classfiles since they belong to the api. each file must be inspected one at a time. since this is done via online link this takes extra time for the response to be received.

btw: startup delay is somewhat related to processor speed and amount of ram in the system. if loading the ide triggers massive swaping due to low ram, hdd transfer speed also becomes a bottleneck. so with a recent machine (lets say 3 ghz, 2-4 gb ram) i doubt there will be any delay felt at all.

Can't you add an exception to your antivirus?