Arduino IDE stuck at compiling sketch

This is my first time working with an arduino. I got an arduino pro mini and i have it hooked up to my pc with an FTDI cable. It's red led is on, and it's green led flashes sometimes. I loaded up the example blink sketch, selected my board, chip, and comport, i clicked upload and it is stuck at compiling sketch and the console reads, at java.land.Thread.run(Thread.java:745). Help

Please enable verbose compile in preferences and post the whole output.

I enabled it and im still only getting the at java.lang thing, am i supposed to look somewhere else for the verbose?

DrAzzy:
Please enable verbose compile in preferences and post the whole output.

This might be it

java.lang.NullPointerException
at cc.arduino.LoadVIDPIDSpecificPreferences.load(LoadVIDPIDSpecificPreferences.java:48)
at processing.app.debug.Compiler.createBuildPreferences(Compiler.java:592)
at processing.app.debug.Compiler.(Compiler.java:193)
at processing.app.debug.Compiler.build(Compiler.java:96)
at processing.app.Sketch.build(Sketch.java:1109)
at processing.app.Sketch.build(Sketch.java:1084)
at processing.app.Editor$BuildHandler.run(Editor.java:1955)
at java.lang.Thread.run(Thread.java:745)

I think maybe 1.6.5-r4 has major problems. I wonder if there should be a beta program, because it seems the posted download may not always be stable.

so ur saying download a different version of the ide?

Yes, I see several posts in the forum today talking about this Java error you are getting. I don't think the guys who posted the current version realize it has this defect. This is the one I have, 1.6.5-r2: http://downloads.arduino.cc/arduino-1.6.5-r2-windows.zip

Fixed in 1.6.5-r5.

https://www.arduino.cc/en/Main/ReleaseNotes

ARDUINO 1.6.5-r5 - 2015.08.28

[ide]
* Fixed a but preventing upload on boards that do not supply VID/PID. See #3738