Arduino IDE Uploading issues

Hey, For some reason, I’m unable to upload code to ANY of my Arduino boards!!!

When I try to varify a simple Sketch like this:

const int ledPin = 3;
const int buttonPin = 2;
int dVal = 0;
void setup() {
** pinMode(ledPin, OUTPUT);**
** pinMode(buttonPin, INPUT);**
}
void loop() {
** dVal = digitalRead(buttonPin);**
** if dVal == (HIGH){**
** digitalWrite(ledPin, HIGH);**
** }**
** else{**
** digitalWrite(ledPin, LOW);**
** }**
}

I get this error:

Arduino: 1.6.12 (Windows 10), Board: “Arduino/Genuino Uno”

sketch\button_high_led_high.ino.cpp:1:21: fatal error: Arduino.h: No such file or directory

#include <Arduino.h>

^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.
This report would have more information with
"Show verbose output during compilation"
option enabled in File → Preferences.

What can I do about this?

First off you need to learn how to use code tags ( </> ).

Any reason you are still on 1.6.12 ?
A lot of win 10 users have reported permissions errors but its hard to guess with not much to go on.
Have you moved any of the Arduino folders recently ?

Maybe a re-install or using the portable (unzipped) version could help.

Also going to send you on a little crash course HERE

I tried uninstalling and reinstalling, and sadly that didn't help...

I'm trying to work with two electronics kits for the kids in my class.

Those kits are MakeBlock and Sparki.

Both are part of the Arduino at Heart series, and both have their own IDEs that I'm trying to use to program them.

Could they be affecting the Arduino IDE?

I didn't start having this issue until I installed these two IDEs...

Thanks, by the way! :slight_smile:

It is plausible that you have conflicting software.

I don’t have access to your other IDE’s and would not want to break my setup to test as I use it for other things Arduino related.

However lets go over some of the basics.

Am attaching TWO PDF with some general troubleshooting and install information.
Maybe you could go through them and pick out parts that may be relevant to your case.

Al also going to download one of the IDE’s as its is relatively safe to play with here as I am going to drop it into a sandbox VM.

Arduino troubleshooting made easy.pdf (522 KB)

CLEAN UP BEFORE INSTALLING ANOTHER COPY OF THE IDE OR ARDUINO CREATE.pdf (345 KB)

Hmmm looks like your "MakeBlock" IDE could be the issue as my sandbox will not let me upload if I have that installed.

From what I can see it seems to put some sort of hold over the serial ports rather than ONLY when selected.
I closed out make and it is still holding on to the ports.
That is very very bad software in that regard.

I used REVO to uninstall it and see what else it would leave behind.
Turns out there were a lot of things for REVO to clean up !
Even REVO suggested I restart as some files could only be deleted during re-boot.
Your software also relies quite a lot on third party software packages such as Adobe Air and quite a few more
Not particularly nice software at all.

I can run multiple other IDE's here and only call the port I need in any of them without affecting the others.

Wow!
Well thank you very much!

I'll contact the company, and make them aware of the issue.

Again, thank you so much for your time!

I ran the same procedure again.
Just to be 100% sure.

During the install for the make program there were a few "new hardware found sounds" but any actual messages about what were found were suppressed by the software.

Again not a good thing !
Software should not over ride these types of message as a user should be able to know what is being installed to either accept or deny a driver that could have been something nefarious !
Every other piece of software that requires a driver here has always requested permission

Same issues with COM ports being locked down and unavailable for other items.
So am now very sure the software "MakeBlock" would not be trusted at this end.
I did not run a security sweep so cannot say anything about that side of things.

Good luck with the company but I would doubt they will be changing the software much.

Ah, okay.

Well, thank you VERY much for all of your time and help! :slight_smile:

I now know what the issue is!