Arduino IDE with Atmega32A

Hello, I am trying to use an Atmega32A with arduino code. I have tried some methods including the one in here: http://www.instructables.com/id/Using-Atmega32-with-Arduino-IDE/

But it isn't working with Arduino IDE version 1.8.0. After editing boards.txt, I can't find the atmega32 board in tools/board menu.
Can you help me using Arduino on Atmega 32A?

Have you really looked for a better alternative? How about GitHub - MCUdude/MightyCore: Arduino hardware package for ATmega1284, ATmega644, ATmega324, ATmega324PB, ATmega164, ATmega32, ATmega16 and ATmega8535

I tried that and used arduino mega as ISP. But here is what I got when tried to burn bootloader.

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is “C:\Users\shuvro\AppData\Local\Arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf”

Using Port : usb
Using Programmer : arduinoisp
avrdude: Error: Could not find USBtiny device (0x2341/0x49)

avrdude done. Thank you.

Error while burning bootloader.

Can you help me solving this?

Select "Arduino as ISP" as your programmer, not ArduinoISP

Thanks