Arduino IDE Won't Open on Mac 10.5.8

Hi Everyone,

I downloaded IDE 1.0.5 for Mac OSX and then copied it to my Application folder. However, when I double-clicked to open it, nothing happened, although Finder changed the time it was last opened. I tried troubleshooting what might cause this problem (Java being disabled) but have not been able to find a solution yet. Any thoughts, suggestions will be really helpful!! Thanks!

Open the Console app nd look at various error logs to see if any useful error messages are generated at the time of the failure. My first guess would be that your Java implementation is not recent enough. Have you checked Apple to see if there is a Java update you can install?

Can your system run a newer version of OS X? I think the latest is 10.9 so 10.5 is getting quite old.

Thanks for the reply! That was an excellent suggestion! I checked console and this is the log that appeared:

Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: [JavaAppLauncher Error] CallStaticVoidMethod() threw an exception Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: Exception in thread "main" Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: java.lang.NoClassDefFoundError: javax/swing/filechooser/FileNameExtensionFilter Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: at java.lang.Class.forName0(Native Method) Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: at java.lang.Class.forName(Class.java:242) Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: at apple.launcher.LaunchRunner.loadMainMethod(LaunchRunner.java:56) Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: at apple.launcher.LaunchRunner.run(LaunchRunner.java:112) Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51) Dec 25 11:26:53 new-host-4 [0x0-0x32032].cc.arduino.Arduino[298]: at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52) Dec 25 11:26:53 new-host-4 com.apple.launchd71: Exited with exit code: 1 Dec 25 11:29:23 new-host-4 kernel[0]: Finder[124] Unable to clear quarantine `JavaForMacOSX10.5Update4.pkg': 30

Do I somehow need to clear the Java quarantine to access Arduino? I can see my problem is definitely tied to Java so I tried a recent update of it for my system. Still not able to access the program. Any ideas on how to fix this or where to look?

I'm not really ready to update my OS X due to other programs I'll have to update too. But if I have to I might end up doing that.

To me it looks like something is missing from the version of Java running on your system. I would try downloading Arduino 0.0.23 which may work with the older Java.

Solved it! I downloaded 1.0.4 and it worked great with my mac. Thank you so much!

  • Download Arduino 1.5.2
  • Move it to Documents or Applications.
  • Open Terminal and enter this command : Java -version
  • Copy the version number
  • Right-click (two fingers of mouse pad and click) on Arduino and Select "Show package contents"
  • In Contents folder, Open " info.plist"
  • Go to JVM version under Java, and enter the full version number without any wildcards(*).
  • Save and run Arduino.

Enjoy

Hope this works for you!

Dropping back to 1.0.4 worked for me, apparently. Will this cause the end of life as we know it?