Arduino- I'm so close!

Using an Acer Chromebook- I've been able to enter all correct info on the terminal to the point where it tells me it's added the Arduino icon, and it has however, the site doesn't load and there is a continuous circle turning inside the icon. Any ideas how to resolve? I seem so close to being able to use my Arduino.

Hi @allanwayne. Are you using the Arduino Create Chrome App?

I don't think so. I was frustrated and deleted it all. I'll go through the process again and be sure I'm using Arduino Create.

If I remember the icon said "Audrino" and not "Arduino Create."

The most common way, and the only officially supported way, to use Arduino on a Chromebook is that app.

I have seen some reports of people managing to get the normal Arduino IDE working on Chrome OS-based machines, but it seems to be a fairly advanced process.

In order for us to be able to help you, it will be important for us to have detailed information about what you are attempting and the problems you're having.

I followed this YouTube video on using a chromebook to the letter and all worked on my chromebook just like the video. I just never got the Arduino site to open. I got the Arduino icon but it just has a continuous circle spinning.

Really appreciate your assistance.

Very cool! That looks like a very helpful video. This is a similar approach to one I saw reported here on the forum.

It's not clear to me what you mean by "Arduino site", but I didn't take the time to watch the whole video so that might be my problem. Please provide the timestamp in the video that corresponds to the step you're stuck at and I'll give it another look.

I can do the time stamp. Great idea. Wish I knew all the correct nomenclature but bear with this 71 year old beginner.

I will get back with you although it will be tomorrow and I'll have that info.

Once again, thanks.

Time stamp is 9:11. At this point my terminal is exactly as the youtube video is showing.

I click search and type Arduino..double click Arduino IDE but no indication, as shown at the 9:27 time stamp, the Arduino IDE is installed.

Thanks.

Try this:

  1. In the terminal, type this text:
    ./arduino
    
  2. Press Enter

Now please describe what you observe. If the IDE still doesn't start, do you see any text printed to the terminal? If so, copy and paste the full text here. Hopefully it will provide some clues as to the problem.

Here it is:
arichx1@penguin:~$ ls
arduino-1.8.15-linux64.tar.xz
arichx1@penguin:~$ wget https://downloads.arduino.cc/arduino-1.8.15-linux32.tar.xz
--2021-06-07 13:24:50-- https://downloads.arduino.cc/arduino-1.8.15-linux32.tar.xz
Resolving downloads.arduino.cc (downloads.arduino.cc)... 2606:4700::6812:1d2d, 2606:4700::6812:1c2d, 104.18.29.45, ...
Connecting to downloads.arduino.cc (downloads.arduino.cc)|2606:4700::6812:1d2d|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 134054724 (128M) [application/x-tar]
Saving to: ‘arduino-1.8.15-linux32.tar.xz’

arduino-1.8.15-linux 100%[===================>] 127.84M 3.28MB/s in 39s

2021-06-07 13:25:30 (3.25 MB/s) - ‘arduino-1.8.15-linux32.tar.xz’ saved [134054724/134054724]

arichx1@penguin:~$ ls
arduino-1.8.15-linux32.tar.xz arduino-1.8.15-linux64.tar.xz
arichx1@penguin:~$ sudo apt-get install xz-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
xz-utils is already the newest version (5.2.4-1).
0 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
arichx1@penguin:~$ sudo tar -C /opt -xf arduino-1.8.15-linux32.tar.xz
arichx1@penguin:~$ cd /opt/arduino-1.8.13
-bash: cd: /opt/arduino-1.8.13: No such file or directory
arichx1@penguin:~$ cd /opt/arduino-1.8.15
arichx1@penguin:/opt/arduino-1.8.15$ pwd
/opt/arduino-1.8.15
arichx1@penguin:/opt/arduino-1.8.15$
arichx1@penguin:/opt/arduino-1.8.15$ ls
arduino examples java reference tools-builder
arduino-builder hardware lib revisions.txt uninstall.sh
arduino-linux-setup.sh install.sh libraries tools
arichx1@penguin:/opt/arduino-1.8.15$ sudo ./install.sh
Adding desktop shortcut, menu item and file associations for Arduino IDE...

done!
arichx1@penguin:/opt/arduino-1.8.15$ ./arduino
./arduino: line 35: /opt/arduino-1.8.15/java/bin/java: cannot execute binary file: Exec format error
arichx1@penguin:/opt/arduino-1.8.15$
arichx1@penguin:/opt/arduino-1.8.15$ ./arduino
./arduino: line 35: /opt/arduino-1.8.15/java/bin/java: cannot execute binary file: Exec format error
arichx1@penguin:/opt/arduino-1.8.15$

Was there a specific reason for using the 32 bit version of the Arduino IDE? I saw you had downloaded both the 64 and the 32 bit versions.

My Acer Chromebook is a 32bit.

I do see I used 64bit at the top. I don't know why. Could that be causing my problem?

I know that this "Exec format error" happens when you try to use a version of the Arduino IDE that is different from the one designed for your system. That could be 32 bit vs 64 bit or x86 vs ARM. Unfortunately, I don't have a specific idea of why you're getting the error.

Since you have it on your computer already, you might try the 64 bit version. You don't actually need to run the installer script. Just untar the arduino-1.8.15-linux64.tar.xz file to some convenient location, cd to the folder, and then run ./arduino.

If that doesn't work, I would recommend trying older versions of the Arduino IDE. 1.8.14 is identical to 1.8.15 for our purposes, so don't bother with that one, but you can try 1.8.13, then I would jump back to 1.8.9 because there was a pretty significant increase in the minimum requirements in 1.8.10 that might have introduced some incompatibilities. You can just change the version number in the URL of your wget command to get the other versions.

I will try these suggestions and get back to you.

How would a person interested in Arduino like me find others in my area who are using it?

Thanks for taking time for me.

See if there is a local "MakerSpace" in your area.

Someone there should be able to guide you.

Although I'm sure it is really great to find people with similar interests in your local area, it certainly shouldn't be considered essential. There probably isn't anyone within a 25 mile radius of me who has even heard of Arduino or the term "microcontroller". But I have an amazing community providing knowledge and inspiration 24/7 just the other side of my computer monitor.

2 Likes

Well, it looks like my chromebook won't work no matter what others have said. Anyway, I'll look for a used Windows 10 laptop and get on with it. I'm ready!

I'm glad to hear you're persevering through the difficulties. Although I think it's really cool that people have found ways to use the standard Arduino IDE on Chrome OS devices and shared that information, I always suspected that it was a tricky process.

If you want to start playing around with Arduino right away, you could try out the Arduino Create Chrome App

Due to not owning a Chrome OS device, I haven't actually tried it, but I suspect that it will be much more of a "turnkey" experience on such a device than attempting to use the standard Arduino IDE.

I'm on the web editor and app. Was able to work with the example "blink." I'll use the tutorial to get acquainted with the UNO.

1 Like