Arduino instillation on Linux

I installed Arduino 1.8.12 on my Linux system and it worked the first time, but every time since then it flashed the opening picture and then just stopped. I run ubuntu on the xfce4 desktop. I have included an image of the screen it flashes when I try to open it.

  • Start a terminal in the Arduino IDE installation folder
  • Type
./arduino
  • Press Enter.
  • Wait for the Arduino IDE to finish starting, or failing to start.
  • Switch back to the terminal window if the Arduino IDE window took the focus.
  • Click and drag the mouse to select all the output in the terminal window.
  • Press Ctrl + c. This will copy the selected text to the clipboard.
  • In this Arduino forum thread, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply, making it easier for us to read.
  • Press Ctrl + V. This will paste the output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.
  • Click the “Post” button.

Hopefully that will give us some information we can use to help you with the problem.

It worked after the first 3 steps. Thankyou!

Well, the instructions were only intended to get more information about the problem. I never expected them to save the problem. Well, I suppose we should just be grateful it's working now. If the problem ends up coming back, let us know and we'll try to help you out.

Enjoy!
Per