Arduino invalid device signature

Hi!

Apparently i have this bug (http://www.arduino.cc/en/Guide/Troubleshooting#toc23). i installed the arduino package for fedora f16. i can't tell if the avrdude included in this package is the modified one. how can i check this? The modified avrdude given at the troubleshoot page (http://svn.berlios.de/wsvn/arduino/avrdude-5.4-arduino/#_avrdude-5.4-arduino_ ) does not compile on my machine (lots of autoconf and automake errors, fixed until a makefile is generated, but it still won't make -- i assume this is broken).

is avrdude patched for every arduino version or are the newer versions compatible with the off-the-shelf avrdude? if there are "fixed" bootloaders compatible with arduino ng i would try to flash them, but i could not find anything reliable on the subject of alternative bootloaders apart from adaboot which seems to be last updated in 2007.

thanks for any help and advice!