Arduino is stuck at uploading

Hi! I wanted to create a bluetooth lamp, and tested it on my Arduino uno. It worked fine, and there was no problems. But when i wanted to make the size of it smaller by using a nano, it didn't upload. it gets stuck at

vrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "D:\arduino-nightly\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600

I tried all the ports, the old bootloader and the new one, and there isnt anything connected to pin 1 or 0.

have you tried (re)installing a recent bootloader on your Nano

Can I do that with usbasp?

you can use your UNO as an ISP

Okay, I will try that

may be this can help

Still not uploading. Tried it twice, and double checked the wiring. The bootloader flashed, but my code won't. Can you tell me what is the default programmer in the ide's settings? Maybe i screwed up there. I'm currently using AVR ISP.

the programer should be AVRISP mkII

Are you seeing the Nano's Serial port? did you pick the right board?

I tried AVRISP mkll, and it only shows these ports.
image
The port 4 is the ardunio nano, I checked in device manager.

It turns out I didn't have drivers installed :sweat_smile:
Thanks for the help!

:wink:
great, have fun

The programmer is only relevant for ICSP, not for upload via USB.