Arduino ISP -> ATtiny85 -> Serial not defined in scope error.

Thanks for any assistance. I am attempting to run the example code for Arduino ISP. I am using an ATtiny Shield to program an ATtiny85 chip. I’ve used this before without issues, however, since upgrading to IDE 1.8.4, I seem to be having trouble. I’ve searched through the forums and online resources, but cannot seem to find a definitive answer to how to resolve this problem. Considering this is an example code, I assume that I’ve done something wrong, but for the life of me I can’t tell what it is. I am new to all of this and my minimal coding expertise is more along the lines of actionscript 2.0 and HTML. And TBH, trying to read these error codes has caused my brain to go infocatatonic. Any help would be greatly appreciated.

Platform: Arduino Uno

Arduino IDE: 1.8.4

Sketch: Example “ArduinoISP”.

Error: See attachment (MS Word .doc). Code exceeded maximum posting length.

Purpose: Program an ATtiny85 chip.

I hope I have followed the proper etiquette with this post. Please inform me if I should post differently. Thanks.

Serial Error ArduinoISP Sketch2.doc (101 KB)

Error messages should be posted inline using code tags. Do NOT post as a Word document.

You need to post the program you are trying to upload to the Attiny85. If it is too long then post the .ino file as an attachment. Please don't post Word documents as they contain formatting that will confuse the compiler.

Your Title suggests to me that you are trying to upload a program that refers to Serial and AFAIK the Attiny85 does not support Serial.

...R

Just posting the orange errors will probably reduce the size significantly. And using a text file instead of a doc will give you a bigger audience.

Ok. Taking into account the recommendations I have saved the errors in a text file with Notebook. The error text exceeded the allowed 9000 characters, hence why I saved as an external file rather than a code snippet.

Also, I am attempting to prepare my arduino uno to program an ATtiny chip. The example file is not what I want to upload to the chip. I am following the directions set forth in the instructions of the ATtiny Shield that I use to program my chip. Here are the instructions I am following.

  1. Open your Arduino IDE (1.0.1 or above). Make sure you have the COM port and your Arduino board set correctly. (done)

  2. Go to File → Preferences. (done)

3.Copy the Sketchbook location mention on this window. (done)

  1. Navigate to this folder (C:\Documents and Settings\Koursaros\My Documents\Arduino) and you’ll find a subfolder named Hardware in it - if not create it. (done)

  2. Download the necessary files for the ATtiny85 ATtiny and extract it in this folder (hardware). This step is only done once. (done)

  3. Restart the Arduino IDE and in the Board section you must have a lot of new choices. Do not change the board yet. (done)

  4. Select Arduino as ISP on the Programmer menu. (done)

  5. Now let’s run the script that will turn our Arduino into an ISP programmer. Go to File → Examples → ArduinoISP. (done)

9 This sketch will also test our shield. The LED we have connected on pin 9 is the Heartbeat LED, that shows the programmer is running fine. Let’s upload it and see if it will light. (done, but with the error mentioned)

So now I’m stuck at this point because the sketch will not run. Please forgive me if I am still not making myself clear. I’m NOT trying to upload the sketch to the chip. If I understand correctly, this sketch is supposed to make my arduino capable of programming the chip with another sketch (I want to program some simple LED to blink in a halloween prop). As I said, I have programmed a few ATtiny 85 chips before following these instructions, but since updating my IDE to 1.8.4 (from 1.5.0 r2) I can’t get it to function properly.

Arduino Sketch Error.txt (30.4 KB)

The sketch I’m attempting to run is found in the example folder.

File → Examples → ArduionISP → ArduinoISP.

The sketch is to long to post in a code snippet, but I’ve also attached the .ino file.

ArduinoISP.ino (16.6 KB)

I solved my own problem. Thanks for the attempt to help, folks. I at least have learned a bit on how to properly post in this forum. The problem was incorrectly setting the board for the ATtiny85 prematurely instead of keeping the selection on Arduino Uno. Dolt! Just goes to show that the simplest solution is usually the right solution. Thanks again.

I'd recommend saving yourself the hassle and getting a USB ASP programmer and just use a breadboard...that and/or buy a ZIF socket and make a quick programming block.

Have a look at these: USBASP v2.0 with ISP 6 pin adapter.

GND -> GND MOSI -> MOSI MISO ->MISO SCK -> SCK RST -> RST VCC -> VCC

Just downlaod the ATtiny85 cores to your IDE via the Hardware Manager: Adding 3rd Party Board to Arduino IDE (16.0.4 +) Reference to JSON files/links to the cores to download.