Arduino ISP not burning bootloader!

I have an Arduino Duemilanove and when i try to burn the bootloader (Atmega328 on breadboard 8Mhz) it says this.

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64
avrdude: stk500_cmd(): programmer is out of sync

I will note that the chip i'm burning the bootloader to isn't a 328, rather a 328P. I don't know if that changes antyhing.

Can anybody help me?

post verbose output please?

i don't understand, what i posted is what it says

I think what you have posted is the standard output if pretty much anything prevents communication between your ISP and your new chip.

Have you checked:

All the pin connections are correct. 10->reset and each of 11-13 to each other.
You have flashed the programming board with Arduino ISP.
You have selected the correct "Target" chip from the list of boards.
You have disabled reset on your programming board.
You have provided power to both boards.

I think I have forgotten each of these at least once.

Is your target chip on an Arduino board or a breadboard? If the latter, have you included a crystal & caps?

EDIT - sorry, you said it was on a BB - I think you need a crystal and caps until you have burned the bootloader. You need to select a board for your target that uses 8 MHz internal oscillator fuse settings if you are then going to remove the crystal. I have used the lillipad bootloader successfully for this. There are many others.

The requested "verbose" output gives the full communication and commands used by AVRdude. I think you hold SHIFT when uploading to put you into verbose mode.

Additional edit - the 328P is actually the "correct" chip. It's the 328 that you have to mess about with.

so i need a crystal and caps when burning the bootloader but i can remove them right away?

That's how I got it to work - added crystal and caps on the breadboard, burned a non-crystal-requiring bootloader (I used a lillipad one IIRC) and then took the crystal away straight after - worked stand-alone on a piece of board after that without needing the crystal. Reprogrammed by serial using the bootloader, again without needing the crystal.

Okay, sounds good! Thank you!

Well i got the components that I needed, and it still doesn't work.
Whats going on?
Error displayed is this

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64
avrdude: stk500_cmd(): programmer is out of sync

Anybody have a solution?


Try posting a picture of your setup. Maybe there is something wrong.

ok i'll post it momentarily, I need to re-make the circuit

Nvm, I can't, I had the setup that was right here

I don't have the crystal anymore, i was trying to solder actual pins on it b/c i accidentally bought a surface mount crystal and as a result of the fail process, I soldered the pin to the actual metal housing as well and would have shorted the crystal.


What's the question? Do you have a crystal in circuit now or not? And capacitors?

Now i have the crystal and capacitors, although i now have a different problem. I've got a different thread going about it