Arduino ISP R3 not working

Hi all,

I would like to program an ATtiny45 or 85. So I got me one of these:

ArduinoISP R3

So I read the info and followed the instructions on these pages:

There is also a getting started guide: https://www.arduino.cc/en/Guide/ArduinoISP
But it says “Retired”

Basicaly I think it’s a driver installation problem ?

I am using: ArduinoISP_WindowsDrivers.zip

(https://www.arduino.cc/en/uploads/Guide/ArduinoISP_WindowsDrivers.zip)

Before driver installation:

After driver installation I see this in device manager:

However, in the IDE port selection is greyed out :

Is it supposed to be when using ArduinoISP or should it be connected to a (virtual ?) com port ?

I have tried:

  • different USB cables, different ports
  • installing, rebooting
  • restarting IDE
  • connecting and disconnecting ArduinoISP
  • tried with and without an attiny connected
  • tried another attiny chip

Uploading a sketch “using programmer” give me an avrdude error:
avrdude: Error: Could not find USBtiny device (0x2341/0x49)

I’m running Arduino IDE 1.6.8
windows 7 32bits

connecting my genuine Arduino micro/uno/mega is not a problem

I’m kinda stuck on this.

Thanks for any help !

000.jpg

001.jpg

002.jpg

003.jpg

004.jpg

005.jpg

006.jpg

(deleted)

spycatcher2k: Choose arduinoISP from tools - programmer.

Tried that too, error message is:

I tried "burn bootloader":

avrdude: Error: Could not find USBtiny device (0x2341/0x49) Error while burning bootloader.

Should I even be using burn bootloader ?

EDIT: Seems I do

Each AVR microcontroller (inluding our ATMEGA328P) has a small chunk of permanent memory called 'Fuses' that control how the chip will behave. These Fuses need to be set in a specific configuration to make the chip Arduino compatible. When you buy a brand new ATMEGA chip from your favorite electronics store, they may not be set correctly. When you 'Burn the Bootloader' to a chip, part of the process includes setting the Fuses. It is a dead simple way to configure a new chip.

Also when trying to upload the blink example: avrdude: Error: Could not find USBtiny device (0x2341/0x49)

I found this post :

if you download the driver (ArduinoISP_WindowsDrivers) on Arduino.cc the file arduinoISP.inf content : DeviceID = "VID_2341&PID_0049"

even hardware can comes with the hardware "VID_2A03&PID_0049"

so change 2341 by 2A03 on this file and start again and it's magic !!!!!

Bad English but it seems like you should replace the VID_ in the arduinoisp.inf file ? I tried both and reinstalled selecting the inf as driver, no luck

thnx for any suggestions

Anyone ?

Pretty please :)

(deleted)