Arduino Leonardo not entering bootloader mode (SOLVED)

I have just recently bought an arduino leonardo for a project but i have run into an issue when trying to upload a hex file onto the board. when i first connected the board to my computer the L light began to flash rapidly 5 to 10 times a second. When i hit the reset button on the arduino to enter bootloader mode it flashes the RX light once for about one second then it goes right back to flashing the L light. i am wondering if there are any issues that can be fixed as i am unable to put the file onto my board.

Hitting RESET once just restarts the board.
Hitting it TWICE quickly puts them in bootloader mode.

Which did you do ?

Could you take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

OMG i am stupid how did i never get that
i was only pressing the button once when i tried it twice it uploaded right away thank you so much i have had this issue for almost a week now trying to find a solution

No worries.
Enjoy your arduino adventures.