Arduino Leonardo Problem Uploading via MAC

Since the 32u4 issues as the follow https://github.com/arduino/Arduino/issues/9290

but the issue is closed i still can't Uploading the Arduino Leonardo.

There is the error message:

Arduino: 1.8.11 (Mac OS X), Board: "Arduino Leonardo"

Sketch uses 3956 bytes (13%) of program storage space. Maximum is 28672 bytes. Global variables use 149 bytes (5%) of dynamic memory, leaving 2411 bytes for local variables. Maximum is 2560 bytes. Couldn't find a Board on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board's reset button after initiating the upload.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to “Show verbose output during: compilation”
  • Check the checkbox next to "Show verbose output during: upload
  • Click “OK”
  • Sketch > Upload
  • After the upload fails, you’ll see a button on the right side of the orange bar “Copy error messages” (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

Hi Global Moderator, I find the issue. It's my Arduino Leonardo have some problem in the bootloader. I change the other board is work. Thank you very much!