arduino\libraries\libraries

For some reason I have nested libraries and I need to have the same files in both of them or I get a compile error as it can’t find one of the files.

I’ve tried uninstalling reinstalling but this did not fix the problem. I’ve searched the win 10 registry looking for a clue but its not in there. This is a line from the compile error dump…

C:\Users\Darnell\Documents\Arduino\libraries\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10805 -build-path

The full dump is below. Its sometimes refers to just arduino\libraries and other times its arduino\libraries\libraries

I’m trying to fix this error. Anybody have a guess?

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Darnell\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Darnell\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Darnell\Documents\Arduino\libraries\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10805 -build-path C:\Users\Darnell\AppData\Local\Temp\arduino_build_48690 -warnings=all -build-cache C:\Users\Darnell\AppData\Local\Temp\arduino_cache_401181 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.1.1 -prefs=runtime.tools.avrdude.path=C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino9 -prefs=runtime.tools.avr-gcc.path=C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2 -verbose C:\Users\Darnell\Documents\Arduino\libraries\Adafruit_BNO055\examples\rawdata\rawdata.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Darnell\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Darnell\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Darnell\Documents\Arduino\libraries\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10805 -build-path C:\Users\Darnell\AppData\Local\Temp\arduino_build_48690 -warnings=all -build-cache C:\Users\Darnell\AppData\Local\Temp\arduino_cache_401181 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.1.1 -prefs=runtime.tools.avrdude.path=C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino9 -prefs=runtime.tools.avr-gcc.path=C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2 -verbose C:\Users\Darnell\Documents\Arduino\libraries\Adafruit_BNO055\examples\rawdata\rawdata.ino
Using board ‘uno’ from platform in folder: C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21
Using core ‘arduino’ from platform in folder: C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21
Detecting libraries used…
“C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\cores\arduino” “-IC:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\variants\standard” “C:\Users\Darnell\AppData\Local\Temp\arduino_build_48690\sketch\rawdata.ino.cpp” -o “nul”
“C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\cores\arduino” “-IC:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\variants\standard” “-IC:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\libraries\Wire\src” “C:\Users\Darnell\AppData\Local\Temp\arduino_build_48690\sketch\rawdata.ino.cpp” -o “nul”
“C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\cores\arduino” “-IC:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\variants\standard” “-IC:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\libraries\Wire\src” “C:\Users\Darnell\AppData\Local\Temp\arduino_build_48690\sketch\rawdata.ino.cpp” -o “C:\Users\Darnell\AppData\Local\Temp\arduino_build_48690\preproc\ctags_target_for_gcc_minus_e.cpp”
C:\Users\Darnell\Documents\Arduino\libraries\Adafruit_BNO055\examples\rawdata\rawdata.ino:2:29: fatal error: Adafruit_Sensor.h: No such file or directory

#include <Adafruit_Sensor.h>

^

compilation terminated.

Using library Wire at version 1.0 in folder: C:\Users\Darnell\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\libraries\Wire
exit status 1
Error compiling for board Arduino/Genuino Uno.

The problem is you set your sketchbook location to C:\Users\Darnell\Documents\Arduino\libraries.

Do this:

  • (in the Arduino IDE) File > Preferences > Sketchbook location > C:\Users\Darnell\Documents\Arduino > OK
  • Move all folders from C:\Users\Darnell\Documents\Arduino\libraries\libraries to C:\Users\Darnell\Documents\Arduino\libraries
  • Delete C:\Users\Darnell\Documents\Arduino\libraries\libraries

Thanks for the reply. I actually figured it out after a month. I didn't see your reply; I had to change my settings.

That's not confusing at all. You'd think they would call it a sketch folder :frowning: