Arduino M0 "USB Device Not Recognised"

Hello, I am having trouble getting the native USB port of the arduino M0 (Not the Pro, mine only has one USB port). Once I connect the arduino to the PC I get the message USB Device Not Recognised.

I am using Arduino IDE 1.8.3 downloaded from Arduino.cc. The M0 is board model R3, purchased from here: http://uk.rs-online.com/web/p/processor-microcontroller-development-kits/8837383/

The installation of the IDE and all drivers went OK as far as I can tell. I have installed the SAMD board library and selected M0 as my board.

In the Device Manager, the board appears under USB as an unknown device.

On reset, the 'L' led flashes rapidly, then once per second. Also, the USB port disconnects, then reconnects with the same message.

I have:

  • Tried under Win XP 32bit and Win 7 64bit and get the same behaviour.
  • I have tried 3 different USB cables of different make and quality. These all transfer data OK when used with my phone.
  • Pressing the reset button repeatedly.
  • Read all of the troubleshooting guide on here: https://www.arduino.cc/en/Guide/Troubleshooting
  • Installed the adafruit drivers package, just in case.
  • Verbose upload, pressing the reset button when the com ports are scanned.
  • Disabling driver signature enforcement.

Any help much appreciated.

Thanks,
Alex

Hi.. I also have trouble with Arduino M0.

Have installed Arduino from scratch.. all new.. Installed the M0 update.
I,m running windows 10. In Port menu is constantly show COM3.
My computer does not react when connecting to different USB ports (Which normally happens)
I see no LED activity at all. Neither by pressing reset.
Also bought my R3 version from RS-online

Anyone have a hint?