Arduino Malfunctioning

I cannot seem to upload sketches to my Duemilanov.

On Ubuntu, the arduino terminal displays: avrdud: stk500_recv(): programmer is not responding
On Windows: avrdude: avrdude: stk500_getsync(): not in sync: resp=0x00
Tried reburning the bootloader: avrdude: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

When I attempt to upload a new sketch, the Arduino RX/TX lights do not do anything. The "L" LED blinks once and that is all. While the IDE is "uploading" the new sketch, the Arduino begins running the previously loaded sketch as if completely ignoring the new data.

Sometimes the IDE will get stuck "uploading" and the TX light on the board will blink indefinitely. To get the IDE out of the loop I can simply reset the Arduino and it finishes, yet displays the same error message above (For windows).

When I first plug the board in to my PC, the "L" LED blinks 7 times after TX/RX blink a few times.

The most strange thing I have figured out is that (On Windows) if I completely unplug all of the data lines that are connected to the board it works fine. I am able to upload without a problem so long as nothing is plugged into the board (not even a 5V, GND, or digital pin). (i.e. the board looks like this: )

I tried this and it works fine: Loop-Back Test Instructions - Installation & Troubleshooting - Arduino Forum

Any suggestions? I was just using it without a problem 24 hours ago. I just purchased an UNO and am going to attempt to use it reload the bootloader and see if that works. Otherwise, I was figuring I would just buy an ISP and program it that way (assuming it works). Are there any ISP devices you would recommend? I was told USBTinyISP is a good one, but for $25 it seems expensive when there are other ISP alternatives for less than $10. Then again, I really do not have a clue what I am looking for.

Arduino 1.0.5



Error message makes it sound like the wrong "serial" port is being selected.

Are any of the connections to d0,d1, and reset?

If not, connections to 5v might suggest whatever you have connected is drawing enough load to trip up the 328s reset.