Arduino Mega 2560 Chinese Clon unrecognized

hello, i've been having troubles with my arduino mega 2560 clon, the first days when i started programming never had any problem, i could upload my sketchs to my board, but suddenly appeared the error of the communication, then i uninstall and install again the drivers but don't work, so i use my arduino uno to burn the bootloader to my arduino, the process was successfully, but when i connected the board to my pc don't recognized it again, then i install again the drivers with no success, now just the led L is blinking and when i check the device administrator don't appear my board and when i connect the arduino uno the board appears. Apparently nobody has had this problem, and they have solved their problem when they burn the bootloader to their board and it didn't work with me. Sorry for my english I speak spanish.

Hi
What is the USB interface chip used in your arduino?

hi thanks for answer, is the CH340G

Hi
Either your PC is not recognizing your CH340 or it has malfunctioned.
Check the device manager if your ch340 shows up.

I've been repeating that and don't shows up. Then I connect my other arduino, by the way also is a clon and shows up.

Was it recognized before you burned the bootloader? Burning the bootloader would not be expected to affect whether the board is recognized because the recognition is entirely about the USB chip on the board, but burning the bootloader does not change that chip at all.


Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable. You know the one you used with the Uno is good, so use that one.

Either of the above can result in the power connections being made (and thus LED lights on the board), but no data connections (and thus no port for the board).

the issue starts when my pc stopped recognizing my board (arduino mega), that was before i did any change to my board, then i connected my arduino uno with the same usb and shows up, then i tried in other pc and it was the same result, so it could not be the usb cable because it works with my uno, so after that i burn the bootloader from my uno to my mega, before the burn of the bootloader all the leds of my mega was always on, and after the burn of the bootloader, only the "L" led is blinking, but still not recognized. And till this point i've tried to find the same issue i have but what i've been watching in all forums, is that everybody have success with their problem when they burn the bootloader to his board and that don't works with me. So I guess the problem is the chip CH340G.

As I mentioned, it is impossible for burning the bootloader to fix this type of issue. It can fix errors with the upload, but it will not ever help with the problem of the computer not recognizing the port of the Mega. So either those people had a different problem, or else they were confused and the problem going away around the same time as burning the bootloader was purely coincidental.