Arduino Mega 2560 non rilevato

Buongiorno, Qualche mese fa ho acquistato un kit Arduino Mega 2560 + Ramps 1.4 per una stampante 3D. Questa settimana dopo aver finito di assemblarla ho collegato l' Arduino al pc per caricare il firmware ma il pc non lo rileva neanche. Quando lo collego di accendono fissi il led ON e il led L, ma al pc non risulta nessun dispositivo collegato, neanche in gestione dispositivi. Ho fatto varie prove cambiando cavo, porta usb, scollegando tutto dalla scheda arduino ma niente. Prima di collegare tutto funzionava, quindi il mio timore è che sia stata la scheda Ramps a fare dei danni.

La mia domanda è: c'è modo di capire cosa si sia rotto e ripararlo? Perché non vorrei che comprandone un'altro e ricollegando tutto si rompa di nuovo...

Se stacchi la Ramps funziona? Hai un tester per controllare la continuità tra i contatti?

>Rebo289: essendo il tuo primo post, nel rispetto del regolamento, ti chiedo cortesemente di presentarti QUI ([u]spiegando bene quali conoscenze hai di elettronica e di programmazione[/u] ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con attenzione il su citato REGOLAMENTO ... Grazie.

Guglielmo

<solo per far dispetto a Guglielmo!> :slight_smile: :slight_smile: :slight_smile:

cyberhs:
<solo per far dispetto a Guglielmo!> :slight_smile: :slight_smile: :slight_smile:

Guglielmo

PaoloP: Se stacchi la Ramps funziona? Hai un tester per controllare la continuità tra i contatti?

Purtroppo neanche scollegando tutta la scheda RAMPS riparte.

Puoi leggere la sigla del chip piccolo della MEGA vicino alla porta USB?

PaoloP: Puoi leggere la sigla del chip piccolo della MEGA vicino alla porta USB?

Spero che sia il chip che intendi

|500x326

Ciao. Visto che monta il 16U2, dovresti provare a riprogrammarlo. Prima però volevo sapere se la scheda, viene rilevata dal PC. Se hai provato a cambiare cavo USB, se hai provato cambiando porta USB o se ha provato su un PC diverso.

E' capitato qualche volta che l'ATmega16U2 abbia "perso" la programmazione. Anche se non si è mai capito il perchè.

Quello é un Arduino falsificato oppure non é un Arduino ma una copia anche essa illegitima (visto che il VendorID della USB non puó essere usato da chiunque ma solo da Arduino /Genuino visto che ciascuno loro lo hanno pagato per la loro registrazione.

Dacci una foto di tutta la scheda e poi ti diciamo se reclamre dal fornitore che non funziona o reclamare per falsificazione.

Ciao Uwe

Perchè contraffatto? Potrebbe essere una Mega .org?

No, non é ne una scheda di Arduino.cc ne una Arduino.org. Quelli da ca 2 anni li producono non in blú ma in blu-verde. Non é neanche una scheda antica venduta in ritardo. Ciao Uwe

Legittima o meno, credo che rientri nella numerosa schiera delle “schede fritte”.
Se non viene riconosciuta in gestione risorse…

PaoloP: Ciao. Visto che monta il 16U2, dovresti provare a riprogrammarlo. Prima però volevo sapere se la scheda, viene rilevata dal PC. Se hai provato a cambiare cavo USB, se hai provato cambiando porta USB o se ha provato su un PC diverso.

E' capitato qualche volta che l'ATmega16U2 abbia "perso" la programmazione. Anche se non si è mai capito il perchè.

Ho provato 3 diversi cavi, cambiato porta e non va, il pc non fa neanche il suono di quando inserisci un dispositivo.


uwefed: Quello é un Arduino falsificato oppure non é un Arduino ma una copia anche essa illegitima (visto che il VendorID della USB non puó essere usato da chiunque ma solo da Arduino /Genuino visto che ciascuno loro lo hanno pagato per la loro registrazione.

Dacci una foto di tutta la scheda e poi ti diciamo se reclamre dal fornitore che non funziona o reclamare per falsificazione.

Ciao Uwe

Ecco le foto:

|500x281 |500x281

Effettivamente la scheda non riporta ne la scritta Arduino/Genuino ne il link del sito :/

Questa scheda era stata comprata da amazon in kit con il Ramps 1.4 e i 4 driver dei motori...

Rebo289: Effettivamente la scheda non riporta ne la scritta Arduino/Genuino ne il link del sito :/

Mi sembra piuttosto evidente che NON sia prodotta né da Arduno né da Genuino, ma sia solo un clone cinese ... ::)

Molto simile a QUESTA .. che costa 8.80 US$ ... e vale anche meno ! Considera che una MEGA originale costa circa 35€ + IVA ::)

Guglielmo

ancora ste storie cloni e processori di seconda scelta......

hanno registrato solo il logo e il bootloader da quello che mi risulta...

quindi non esistono cloni.

... [u]e ti risulta male[/u] ... :smiling_imp:

... i disegni, gli schemi, le board, ecc. sono sotto licenza Creative Commons Attribution Share-Alike ... il software, ... è parte sotto licenza GPL e parte LGPL

Magari datti una letta alle FAQ ed alla policy ufficiale che si trova QUI ... così capisci pure le regole che i produttori devono rispettare !

Comunque, NON ho parlato di "copia illegale" (... esistono pure quelle), ho parlato di clone, cosa del tutto legale ... ... difatti il problema NON è nella legalità, ma nella qualità che spesso questi prodotti da quattro soldi hanno.

Guglielmo

Rebo289: Ho provato 3 diversi cavi, cambiato porta e non va, il pc non fa neanche il suono di quando inserisci un dispositivo.

Questa scheda era stata comprata da amazon in kit con il Ramps 1.4 e i 4 driver dei motori...

È una delle schede copiate che vogliono apparire allo primo sguardo un Arduino originale.

Comunque al Tuo problema chiedi al venditore di cambiartela.

Ciao Uwe

elpapais: quindi non esistono cloni.

Esistono i cloni di Arduino, schede praticamente identiche ma con nome diverso, esistono i cloni illegali, schede identico con nome Arduino e serigrafia copiata dall'originale, esistono le compatibili, schede che hanno delle differenze nello schema, nelle funzionalità e il nome è diverso. Sopratutto esistono le schede cineseria, non importa se cloni, compatibili, copie illegali, dove vengono usati componenti di seconda scelta, in particolare il micro, visto che non è possibile vendere un oggetto a meno di quello che costa in produzione se fatto come si deve.

astrobeed: Sopratutto esistono le schede cineseria, non importa se cloni, compatibili, copie illegali, dove vengono usati componenti di seconda scelta, in particolare il micro, visto che non è possibile vendere un oggetto a meno di quello che costa in produzione se fatto come si deve.

Ed aggiungo. Quello che dice @astro NON vuol dire che la scheda non funziona per niente. Vuol dire (ed è già capitato) che per fare le solite prove e progettini magari la scheda va, perchè ci limitiamo ad accendere led o leggere un semplice sensore. Ma alcuni progetti più complessi, dovendo fare qualcosa di più dei semplici sketch, poi la scheda da risultati anomali. Esempio in un thread si parlò di un progetto dove una Uno doveva essere programmata a basso livello, aumentando la velocità di campionamento ADC. Il clone cineseria dava moooolti problemi, l'originale no.