Arduino Mega 2560 Not Detected


I just bought an Arduino Mega 2560 clone (Funduino) and installed the drivers as per this websites instructions, however, the device does not show up anywhere in device manager, using three different computers running XP, Vista, and Windows 7. I already have an Arduino Uno clone working on one of the computers with no problems, but nothing at all happens when I plug in the new Mega board. I also tried using two three different USB cables to no avail. The ‘ON’ LED on the board does light up green and a red LED (connected to pin 13?) blinks a few times after connecting the board, and then goes off. Does anyone know how to fix this problem? There are 2 sets of jumper pins (6 next to the reset switch, and 6 near the USB jack), do any of them need to be jumpered?

there is an answer to your problem somewhere here or on another forum with pics and everything. Summarizing, try to download an older version of the IDE that has the 2560 driver in its "drivers" folder. go to your device manager. click on ports you'll see an unknown device (unless your computer has a problem) then, right click and choose to update driver get to the point where you get to choose a driver manually, pick the 2560 driver in the drivers folder in in the folder of the older IDE it should install and the grass will be green

if not, let me know so I can find the source that gives more details because I had similar problems with different clones and boards

The problem is that the board doesn't show up in device manager at all (not even as an unknown device). The computer isn't to blame since I've tried with three different computers and the board doesn't show up in any of their device managers. Does anyone have any idea what the problem is?

md64: I just bought an Arduino Mega 2560 clone (Funduino)

Go back to the entity that sold it to you. They know more about it than anyone on this board.

md64: and installed the drivers as per this websites instructions,

Instructions on this site are for official Arduino boards. Clones and Deritiviates may have differences, like the use of a different USB to Serial chip.

in the device manager, did you click on ports to expand it? if you did, you should see an unknown device and you can start from there. I had the exact same thing happen to me when I first used them.

Instructions on this site are for official Arduino boards

What is "official"?!?! I can copy "official" ones and start selling. Try to review the license they used.

I always use those Chinese clones for a small fraction of the price, even though I'm Italian (it's an open-source project anyway, right?) and I don't like exaggerated prices of copy-paste-ers in some countries where citizens pay huge taxes and the bourgeoisie way of thinking here (the more expensive, the more reliable). It's just a 2-layer PCB with a handful of components soldered and a bootloader in the microcontroller chip. Everything is open-source and total illiterates can make it with the right tools. I love "cheap labor" until they have some kind of democratic revolution or something.

Hi, MD64 Have you found a solution to you problem? I have the exact same problem with 2 of them. Mine are from the vendor goodlucksel purchased from eBay.


I never managed to get the board to work, however, I contacted the seller (goodlucksell) and they refunded my in full (price + shipping).

I also purchased Funduino ATmega2560-8AU from goodluckbuy that is not discovered by Computer. I could use second Arduino to program the atmega and usb chip over ICSP header after that the uploaded program did work. I didn't go for the refund but for replacement which has the same trouble, it is not recognized by computer, reset does not work, both usb data line are grounded. :(

After some time i bought FT232RL (FTDI USB-TTL) to program them over Serial port but the problem with reset button makes it hard to find exact moment. After that they ware laying around for some time :sleeping:

Now after using up my working mega's to other project (Xively uploder and temperature reading over gsm) and after searching for solution to reset arduino with ftdi modul when programming it, they are back in business. :)

Regards Rihard

thanks for reading my first post on Arduino Forum

the solution to reset arduino when programmed over Rx/Tx with FTDI chip (Vcc -- R10k -- reset pin -- +|100uF(- -- DTR) was found

I am nor sure if this was a good buy "two partial working boards for price of one" but I had some luck and get some tinkering experience :D