Arduino Mega 2560+ PS2 Mouse Problem, Serial, No feedback

Hi all,

I am trying to connect a ps2 whell mouse to my arduino mega 2560. I am using arduino 1.5.2 (nightly windows). I am using the library and code from with changing the WProgram.h to Arduino.h. I can compile and upload the sketch to my arduino mega.

However, when I open the serial monitor, nothing happens, not even some silly numbers, simply nothing. I tried to connect the mouse but it did work either.

I tried some other libraries from internet (maybe all of them) which are based on the library above but none of them worked.

I think the problem lies in this line:mouse.init(); it does not initialises the communication.

Some suggestions are to add Serial.begin() before and after the mouse_init(). I add the Serial.begin() before and after that and it prints before but nothing after.

I appreciate your helps and have a nice day

Thank you


ps2_mouse.pde (1.33 KB)

SOLVED!!! Hello I know this topic is old I had the same problem Was solved by changing the mouse Note that if the mouse is not appropriate or is interrupted, the program stops and does not report the number zero.