Arduino Mega 2560 R2 Won't Accept Drivers

I have tried this so many ways on various OS's I can only think at this point that it has to be a bad board. But I will reach out and hope that someone can shed some light on this.

I have the Board listed in the title. I have Win7 64bit PC that I first tried to install this to. I have stated the PC to enable unsigned drivers. I have tried this on a Win 7 32bit laptop. I even tried it in XP mode and it did not install.

The device shows up as 'ATmega8U2 DFU' under 'Other devices'. I chose to select a path and pointed it to the drivers directory (not the FTDI sub folder) and only get the following message after pointing it to that directory "windows was unable to install your ATmega8U2 DFU"

There is a green light labeled 'on' that is lit and that is all. I have been trying for months to get this working. Every once in a while I try with futile results. Is this a bad board that somehow made it through testing? I have tried so many searches and they all seem to revolve around not pointing it to the FTDI directory or enabling unsigned drivers. But neither of these have worked.

Is there a way I am unaware of to force a driver to a device?

‘ATmega8U2 DFU’ is a strange name to me. For me, it was written “Arduino Mega 2560”.

Today, I received from China an Arduino Mega 2560 with its sensor shield. I bought them online for $33, which is not expensive, but it turns out the mainboaard is not a R3. I was browsing the forum in order to know if I have an R2 or the previous version. It is said the difference is a resitor, but I don’t where this resistor is located and how it looks like.
Anyway, I have successfully installed the driver, and I have carefully noted what happened. I have Windows 32-bit.

  1. At first, when I connected the board to the USB port of the computer, I was told there is no driver for that device.

  2. In the configuration panel, system, devices, I found a line “Other devices” (or rather “Autres périphériques” because I have Windows in French), and underneath there was another line: “Arduino Mega 2560” with a yellow exclamation mark.

  3. I donwloaded the latest drivers from this site, “”. I extracted its content (maybe that’s something you forgot). Now in C:\test\arduino-1.0.3\drivers, I have:

18/01/2013 13:21 3 428 Arduino Esplora.inf
18/01/2013 13:21 3 324 Arduino Leonardo.inf
18/01/2013 13:21 3 324 Arduino MEGA 2560 REV3.inf
18/01/2013 13:21 3 318 Arduino MEGA 2560.inf
18/01/2013 13:21 3 322 Arduino Mega ADK REV3.inf
18/01/2013 13:21 3 211 Arduino Mega ADK.inf
18/01/2013 13:21 3 318 Arduino Micro.inf
18/01/2013 13:21 3 312 Arduino UNO REV3.inf
18/01/2013 13:21 3 307 Arduino UNO.inf
18/01/2013 13:21 3 207 Arduino USBSerial.inf
18/01/2013 13:21 FTDI USB Drivers
18/01/2013 13:21 3 322 LilyPadUSB.inf

And inside C:\test\arduino-1.0.3\drivers\FTDI USB Drivers, I have

18/01/2013 13:21 .
18/01/2013 13:21 …
18/01/2013 13:21 amd64
18/01/2013 13:21 26 094 ftd2xx.h
18/01/2013 13:21 12 114
18/01/2013 13:21 5 324 ftdibus.inf
18/01/2013 13:21 11 210
18/01/2013 13:21 5 218 ftdiport.inf
18/01/2013 13:21 i386
18/01/2013 13:21 42 808 LogoVerificationReport.pdf
18/01/2013 13:21 Static

Check if you have the same list. Sometimes, files are not well unzipped, or subdirectories are not created when unzipping.

  1. I clicked on my line: “Arduino Mega 2560” with the yellow exclamation mark.
    The first tab of the properties window said: “Les pilotes de ce périphérique ne sont pas installés. (Code 28) …” (the drivers of the device are not installed…).
    So I clicked on the button below “Mettre à jour le pilote…”.
    I selected the option to search the driver on my computer.
    I selected the location of the folder of the driver: C:\test\arduino-1.0.3\drivers .
    I had an alert (from Avast) asking if I want to continue, I said yes.
    No errors. I close the window of the installation of the driver.

  2. The property window which was in the background is now in front, and the text has changed to “Ce périphérique fonctionne correctement.” (this device is working correctly).
    I close that window. The window of the devices does not show anymore “Other devices”. I find my Arduino Mega2560 under “Ports (COM et LPT)”.
    Then, I check with the blinking code, and also with a customized slow blinking code (after having selected the type of the board and the port in the IDE).