Arduino Mega 2560 R3 will not enumerate

Help! Been pulling my hair out for 5+ hours on this.

mega 2560 r3 will not enumerate. Will not show hardware ID. On two computers. Installed all the drivers. I tested different cables. I have an UNO, it enumerates fine, it shows the hardware ID. It installs and works perfectly.

Do I have a bad board?

What operating system?

It is possible the ATmega16u2 isn’t programmed.

AT this point I feel like that's exactly what the problem is. But how can I program it if I can't communicate with it?

It's on Windows 7.

I booted into Ubuntu to give it a shot and it didn't work either.

Any thouhts on how I can fix this damn thing?

It looks like a legit board. Says arduino.cc and has all the info printed in it. Got it as part of a RAMPS package from gadgets3d.com for my 3d printer. It's the last leg of the journey and what should be the last 10 minutes has turned into 7 hours of hell at this point.

To sum up: How do I bootload this thing?

Edit: It's got a soldered chip. Atmel Atmega2560 16AU 1309

raeliean: Any thouhts on how I can fix this thing?

Try following the DFU instructions.

http://arduino.cc/en/Hacking/DFUProgramming8U2

I tried FLIP 3.4.7 and it can't seem to find the device.

I tried programming the 2560 using my uno as an ISP as instructed here http://www.gammon.com.au/forum/?id=11635

Still no luck.

Device cannot install drivers or enumerate ID's.

Just wanted to wrap up this thread.

The arduino mega 2560 was bad. The retailer shipped me a new replacment and as soon as I plugged it in, it took drivers automatically.

The old one I tried to program using uno as ISP. This would put on the bootloader, but I was unable to upload using the uno as a programmer. It's in my box and maybe I will toy with it later.

Thanks for the responses, it was great learning !