ARDUINO MEGA 2560 REV3 USB port communication problem

Hello everybody, Some time ago I bought an ARDUINO MEGA 2560 REV3, installing it on a labtop working with XP without problems. I must say from the beginning I had some problems with the usb serial port of the board. So I changed the cable because the electric contact of the socket was too poor and seemed to solve every communication problems. Since some days I mounted a motor shield (VNH5019 MOTOR DRIVER SHIELD) on the mega 2560 board to control two dc motors and after that I experienced again communication problems on the USB port that continually appears and disappears. I tried to reinstall the drivers but nothing happened, no communication seems now possible between the pc and the board. Now I'm trying to understand if the board is still working or not. I tried to follow the loop-back test Instructions but when I insert the USB cable it doesn’t make any sound at all. Is it sufficient to say that the board is broken or what could I do to verify it?