Arduino Mega 2560 Serial port troubles[solved]

Hi everyone,

I get some troubles to communicate via the 3 extra serial ports of my Arduino Mega board.

I made a program to transcript GPS trames to AIS trames to be read by a Navigation software, until now it worked fine, and since I upgrade Windows 8.1, I can’t communicate with the Serial ports but the USB serial.

The Serial USB port is working fine (blinking Tx led for a test pg), but when I use either Serial1, Serial2, and Serial3 for the same program, I can’t get the signal that should appear. Even the Tx led is not blinking.

Here is the program that im using to test the serial ports.

void setup(){
// Serial.begin(4800);
Serial1.begin(4800);
}

void loop(){
// Serial.print(“test”);
Serial1.print(“test”);
}

I am using Windows 8.1 64 bits. I may have forget some informations, it is the first time I post on the forum :).
If anyone gets an idea about where this is comming from, I don’t know what to do anymore

Thanks

(deleted)

Hi, thanks for answering.

I read the serial from a serial reader software,Termite, via a Max232 ship. It works fine during the past 2 mounth.
Do you think it may be due to a wrong driver installation? The Tx and Rx leds should be blinking anyway if I send something from the serial1 2 or 3 right ?

Thanks

(deleted)

Ok, thank you, I finally found a default in my DB9 plug :*

A shame that you lost some time for my problem sorry!!

Thanks for the infos anyway. It was a good reason for me to suscribe to the forum :).

Vincent

(deleted)