Arduino Mega 2560 shows up as "HID-compliant game controller" in Win10 Device Manager

I am having issues with my Arduino Mega 2560 showing up as a HID-compliant game controller. I'm not sure why it is doing this, but any help would be greatly appreciated.

I figure it has to do with the driver Win10 is trying to use for it, but I am not sure how to change the driver.

Your board might be second hand. Or did you play with UnoJoy?

You can burn the original firmware of the 8U2/16U2 TTL-to-USB converter if you have a programmer (other Arduino will probably also work). I have never done it so not sure.

I might have tried that but I am not sure. Going to try a programmer I found here

https://www.arduino.cc/en/Hacking/DFUProgramming8U2

from this thread

I do not have another Arduino board, but I'll see if I can do it with just this.

Thanks

sterretje it worked using the atmel flip software and the firmware. Thanks for the suggestion.

What does that word mean?

Oops sorry Whandall I meant firmware instead of fireware