Arduino Mega 2560 - sudden unknown USB device

Hi, im new here and not much experinced in these things. So im trying it here if someone would know, what could cause my problem or if there could be some solution. Everything was working fine for couple of months, but suddenly, when i try to conect Mega to a computer, it starts saying that USB device was not recognized and its making this in a loop, still making connecting sounds. I have tried to connect it to a different computers with win XP and 7, or changing the cable, still the same problem. Could it be dead or could there be some solution? Thanks

Did you power the Mega by connecting a 5 volt supply to the 5v bus?

I have had similar problems which can show as: 1. Tools / Serial Port grayed out 2. Serial Portx already in use. 3. Hangs on upload 4. avrdude not in sync. These are caused by not downloading the right drivers. The Arduino IDE automatically downloads drivers, but does not always get the right ones. This is especially a problem if you are working with two different boards, e.g. Mega and Nano. Follow your board documentation to identify the right driver, and manually download it.