Arduino Mega 2560r3 USB won,t recognize but lights ON

Hello

I have a problem with my "Arduino Mega 2560r3".
When I turn on USB port "green ON" and "yellow L" constant glow but the computer does not recognize the PCB.
We tried a Reset button but nothing changes.
I can not upload firmware from "Marlin Arduino 1.0.6" on the board.
Does anyone have any ideas why it does not work.
I'll be glad if someone help

Regards
Peter

Have you try removing both the external power and USB? I have an Uno r3 here and had a similar issue and by removing all power to the board allows everything to reset on on the board and then to computer will see it again.

I've some problem for a 2 months.
I've tried to some way to recognize my win7 64 bit, but I could not be succesfull. I've tried to my friends computer which is win8.1 and its work.

I've download ch341ser ( usb driver for win) but it doesn't works still.
:frowning:

When it is plugged into a Windows 8 box does it come up as a CH340 USB to serial port? If so, what does it come up as in device manager on Windows 7?

Mega R3 should not come up as CH340 - that's a different USB/Serial driver. If the board has that it is not a real Arduino.

I suspect it is a clone of the Mega 2560 with a different USB to serial converter.