Arduino mega - 5V Relais 8-Channel 230V - sticks

Hi Guys,

So I use an Arduino mega that triggers a 5V Relais 8-Channel 230V.

Now I have the problems that the relais sometimes stick. I hear the relais switching and the indication light of the relais also switches. But the relais don’t move.

I use 5 of the 8 relais, 2 of them for general light bulbs → Works perfectly
1 of them for a led strip → Works perfectly
1 of them for 2 LED spots - > Works perfectly
1 of them for 2 LED Spots → that relais keeps sticking, I tried to put it one another relais but no success, I tried all 3 reserves relais but it keeps only sticking with those 2 spots.

Any suggestions?

Thanks!

Try a solid state relais, but be sure it is a good one that can be used for the mains. They have often a speak voltage suppression in the module.

Your relay module is probably not safe to use with 230V anyway.
Do you know what it sticking ? Is it really the contact pins that are melted together ? That can’t be good :astonished:

What is the exact type of relais (link) ?
How do you power the relays ?

This is the relais that I use now ( 5V Relay 8-Channel High-active or Low-active - 5VREL8HL ) It is made for 230V 10A, so I think that must give no problems for the led spots that use ±0.5A.

Yes, maybe it is better that I switch to solid-state relays.

And yes it is the contact pins that sometimes melt together.

This is the relais that I use ( 5V Relay 8-Channel High-active or Low-active - 5VREL8HL )

  • I power it trough 5V and ground from the Arduino. The relais are triggered trough the DI from the Arduino Mega

How much current do these lights of yours draw?

Some led lamps use a capacitive voltage divider or just a single capacitor to lower the voltage for the led. It is possible that only 0.5A causes trouble with those relays.

The relays have written on them that they are for 250V and 10A, but they could be clones/counterfeit/fake.
The relay module as a whole is probably not made according to the rules for the main voltage.

On the Arduino side, the 5V needs to power up to 8 relay coils and up to 8 inputs.
About 71mA for the coil and let’s assume 5mA for the led and 10mA for the optocoupler. That makes a total of 688 mA that the Nano board has to deliver. That could be too much.

That is not such a good idea…

Yep, the regulator that’s on the Mega usually comes in a sot-223 package, and those have a maximum rating of 800mA (or only 600mA), that is cutting it way to close. The reason that the relays on the board or driven by an opto-coupler is also so you can drive them from separated power sources.

Or to be precise, it is total rubbish for an 8 relay board! :astonished:

Yo Guys,

I fixed it trough letting the Arduino relais triggering an industrial relais, that industrial relais switches the LED spots. No problem till now!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.