Arduino Mega Controller Problem (Chinese)

I´ve bought this:

When I plug in the board, Windows 10 doesn't recognize it.
I have tried to look for the drivers online, I have tried with youtube videos and to install the CH341SER driver and nothing.

Anyone can help me? Thanks

I have not seen this before but I will take a SWAG. Do you have other Arduinos you can try? Have you tried a different cable? Do you have access to another computer to try your board? This is 3 seperate "Arduinos" fully integrated on one board: Mega R3 ATmega2560 and WiFi ESP8266, with 32Mb (Megabyte) memory, all modules can work together or separately. They all have their own pin headers. This was designed so you can develop a convenient solution for new projects that require Uno and WiFi. Via USB, you can update sketches and skins for ATmega2560 and ESP8266. For this purpose, there is a CH340G USB serial converter on the board. Using this table is very simple. There are DIP switches on the board to connect modules like: USB and ATmeg2560, USB and ESP8266, ATmega2560 and ESP8266." This is from the add, have you done anything with the switches etc. Are there any instructions included? It sounds like a nice board only missing information on how to use it. Let us know how you do.

There are DIP switches on the board that determine the connection configuration of the CH340 USB-UART converter. Study them. It is not clear from the description how to install them correctly.

H60f39baba3cf4b4daa8281c65c7bd63dG

To connect to the arduino via Micro USB, I have connected switches 3 and 4. But it still doesn't work.
I have tried it on Windows 10 and Linux.

Your phrase needs clarification.
If you have selected the correct configuration and installed the driver for the CH340G, then when the device is connected, Windows Device Manager should show in the Ports section the USB-SERIAL CH340 (COMxx) device, where xx is your port number.

2021-05-12_113855

What is your device manager showing?

Have you contacted the vendor for help? Hopefully they have some examples on how to make it work.

Finally, I´ve found the solution switching on the switchs 3,4,5,6 and 7. Thanks for your help.