Arduino Mega lights are on but no one is home

I'm just gonna preface this by saying that I'm pissed at this stupid device.

I've bought numerous arduino boards, all but one are from china(guess the one that broke), and at this point I'm only buying the cheap crap from there cause as of right now I have a $60 worthless piece of crap. That worthless pile is the Mega I bought thinking it wasn't going to die on me or at least not that easily.

But it has, it no longer resets when you press the reset button, it ignores everything including the FTDI I have that I tried to use to bypass the USB port. there is no visible issues with the board or the components and nothing has experienced no overcharge or excessive heat.

yet one day I plug it in to work on some PWM and the damn thing just beams the TX, RX and Green ON LED, they stay on and steady thats all it does now. doesn't connect to any comp using any cable and obviously doesn't show up in device manager.

I've tried my google-fu to solve this but I can't even figure out where to start to ask, and any similar issues usually have the answer of, "Hardware is F****" So with that if anyone has an answer that would mean the world. However I get the feeling this thing is trash and I really should never spend more then a few dollars on these things ever again.

I have a Mega and it has lasted over four years. You have odviously done something, connected something wrong to brick the board. You could use a DMM to probe around and see if the voltage is right on supply pins. That would be my first move.

yup all the pins are reading correct voltage, and it does appear there is power draw from the chip. I read somewhere the firmware may be the issue but I’m not sure if that’s really it :confused:

the board just seems stuck, like it has code running on it blocking it from communicating. is there a way to reset the memory, or flash the chip clean?

I’m honestly grasping at straws here :<

Try the Loopback Test. Connect D0 to D1, hold reset down. Type some characters in the serial monitor, they should be echoed.

Working? Continue.

Select File:Preferences, turn on Verbose outputs.
Press & Hold the Reset button.
Download a simple sketch, like Blink.
When the IDE shows "compiled xxx of 128xxx bytes" release Reset.
May take a couple tries to get the timing right.

well I couldn’t get the reset button to do anything, and jumping pin D0+D1 made no change.

I get this error read out when I connect to the mega via an FTDI to the RX & TX pins:

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf”

Using Port : COM4
Using Programmer : wiring
Overriding Baud Rate : 115200
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

so I can’t actually get the board to show up in device manager as itself to have the loop back test work.