Arduino Mega, microSD with SD adapter , sdformater fails

Hi,

I've been working on a device composed of an arduino, an lcd, a keypad, a sd card module and a nfc reader.
The goal is to do many different actions like dumping, reading, writing, comparing keys of mifare classic cards.
I have use this SD module :

with a PNY 16Gb (class 4 i think), without any problems.
But i used my SD card for another project and decided to change to a micro sd card with an SD adapter : an kingston SD 8G class 4 (it was the only one i have available).
But since i changed i cannot write using the arduino on it !
The most strange is that i can use it on my computer without any problems.
I tried to format it using SdFormater and here is the output :

This sketch can erase and/or format SD/SDHC cards.

Erase uses the card's fast flash erase command.
Flash erase sets all data to 0X00 for most cards
and 0XFF for a few vendor's cards.

Cards larger than 2 GB will be formatted FAT32 and
smaller cards will be formatted FAT16.

Warning, all data on the card will be erased.
Enter 'Y' to continue: Y

Options are:
E - erase the card and skip formatting.
F - erase and then format the card. (recommended)
Q - quick format the card without erase.

Enter option: F
Card Size: 7384 MB, (MB = 1,048,576 bytes)

Erasing
................................
..........................
All data set to 0x00
Erase done

Formatting
Blocks/Cluster: 64
FAT32
error: write MBR
SD error: 13,0

and when i format it on the computer, it works well, i can move the old data on it, but back to the arduino, the arduino fails at first mkdir ! (write).
Can this come for my SD card module ? or from the microSD adapter ? or the microSD itself ?

Thank you all for your help.

Regards,

--
Ulysse31

Have you tried the SD without any other devices connected to the Arduino?

That SD card does not have a logic level converter, so the 3.3v inputs on the SD card are getting 5v from the Arduino. That has been known to cause problems.