Arduino Mega port not visible

I am unable to upload my code to Arduino Mega even though the previously uploaded code is working fine i.e. Mega is working fine the port is not working the usb port doesn't show up in the IDE and in device manager it appears as a faulty usb device (Usb Device 2.0) , my usb port works as a power cable, I have tried all the troubleshooting methods available online but nothing is working.

(Micro controller is working, upload port is not working)

Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable.

Either of the above can result in the power connections being made (and thus LED lights on the board), but no data connections (and thus no port for the board).

I have checked with everything twice and have tried multiple cables still no results at all, i think I might have fried the 16U2 programmer ic of mega can suggest me anything on bypassing 16U2 ic??

You can try to re-install the driver.

If you just need communication from your sketch to a computer, you can buy any so-called FTDI cable or breakout board. If you also want to be able to upload, you will need one that also has DTR/CTS. You can do a search for e.g. sparkfun ftdi - Google Search.

If you need a very flexible programmer, a number of eople swear by the Pololu USB AVR Programmer v2.1 I have the V2.0 version

  1. generic TTL-to-USB converter (e.g. for ProMini that does not have it)
  2. can program via USB
  3. can program over ICSP (e.g. in case you want to burn the bootloader)