Arduino MEGA Problem with programming.

hi all, the problem im having is with a new mega that i got. it wont except programming anymore and i dont know why. i get the dreaded stk500: getsync etc.... error. i figured the bootloader may be corrupted somehow so i tried to load it useing my usbtiny isp and i get the following error. i checked the programmer with a duemilanove and the bootloader installed perfect so its not my computer or the loader. id like to be able to erase the chip and start from scratch but im not sure how to do that so im comeing to you guys. if there is any more information i can give you just ask. and im useing the latest IDE 17.

here is the error.

You never stated if you tried to select the correct Board, when you try to burn or upload.

If it's giving you this error when you try with the Mega, but not the Duemilanove, try changing the board under Tools -> Boards -> and choose Arduino Mega.

When you switch between the Duemilanove and the Mega, if you're uploading, OR burning a sketch, you'll ALWAYS have to change the board under the Tools menu.

I've been using my USBTiny to fix broken bootloaders for some time now.. and it's worked fine on my Seeeduino Mega, so I'm sure it's not a programmer issue. :)

You won't need to select the correct Com port if you're burning a bootloader, like you're trying, but if you try to upload to the Mega, you'll also need to choose the correct COM port under Tools -> Serial Port. If you're not sure which it is.. un plug the board, check under Tools -> Serial Port, then plug the board back in, and check.

thanks forthe help. yea what i meant was when i select duemilanove to program a duemilanove its works. when i select mega to program a mega it gives that error. i though to confirm its the bootloader i used avr studio to program the board and it goes 100% no problem and verifies. so im not sure what to make of it. i still get the getsync error when writeing and im at a loss at this point. im wondering if there is a arduino repair store i can just send it to a pro. i dont want to throw this one out at 70$ but something is defietly wrong with it.

I have the same problem with the same error. I use my USBtiny a lot on different other chips so I know it works. I get the mismatch error as reported: "0x0c != 0xff". Interestingly when I try to read the flash back using avrdude it returns an empty file indicating an empty flash. There is a bootloader on the board though as I can upload sketches through the serial link.

I am using arduino-0018

i solved the problem it was something with my programmer. i broke down and got a avrisp mkII or whatever its called and problem solved. the boot loader was corrupted. so im not sure what to say about yours but that small programer seems to have issues programming the mega.