Arduino Mega rev3 + GSM + Micro SD

Greetings,

i am quite new in Arduino world. I want to make my project work but i have few issues.

I have:

  1. Arduino Mega rev3
  2. GSM Shield (http://arduino.cc/en/Main/ArduinoGSMShield) with integrated antena
  3. Micro SD card Catalex
  4. Load cell with HX711 controler in between.
  5. Sensor for temp. and hum.

Everythings works, except SD Card ..

if i try official library for SD .. initialization failed. Things to check ... etc ...

i connected connectors first:

** MOSI - pin 11 ** MISO - pin 12 ** CLK - pin 13 ** CS - 5 that is connected on gsm shield and try pinMode(10, OUTPUT); and any possilbe combination from 53 to xy number but no effect

then i tried: to change RXPIN to any on avaiable... RX: 10, 11, 12, 13, 14, 15, 50, 51, 52, 53, A8 (62), A9 (63), A10 (64), A11 (65), A12 (66), A13 (67), A14 (68), A15 (69).

i tried from A8 to A15 but no luck (even GSM didn't connect) ... ofcoarse i did bridge pins 2 and selected pin instead of pin 10.

so i tried.. to connect mega + sd card.. works perfect on pins 11-13 and 50-53... no problems here

i know that both GSM and SD uses pin 10 .. but that officaly dont go ...

basicly i tried everything posted on any forum.. which could bring me a solution...but no luck.. card is not inicialized..

anyone with any idea?

would save my a lot of nurves and time

anyone with solution or hint maybe?

Everythings works, except SD Card …

if i try official library for SD … initialization failed. Things to check … etc …

i connected connectors first:

** MOSI - pin 11
** MISO - pin 12
** CLK - pin 13
** CS - 5

That is good for an Uno, but not for a Mega 2560. This is correct for it:
MISO = D50
MOSI = D51
CLK = D52

SurferTim: That is good for an Uno, but not for a Mega 2560. This is correct for it: MISO = D50 MOSI = D51 CLK = D52

it works.. you made my day:) thanks big time