Arduino Mega "USB device not recognized" Windows 8

I’ve had an Arduino Mega 2560 for over a year now and it worked great with my last laptop. I recently upgraded to a Windows 8 laptop and now whenever I plug the Mega in I get the “USB device not recognized” pop up error. The weird thing is that it iis immediately recognized on a different machine running Windows 7, so I know it’s not the board. This leads me to believe its a driver issue.

Nothing shows up under Device Manager which prevents me from updating the driver manually for the board. I’ve tried enabling unsigned drivers and installing the Mega driver .inf file by right clicking on the file, but I still get the same error!

Things I’ve tried so far:

  1. Switched the USB cable
  2. Tried all 4 of my USB 3.0 ports on my laptop (There’s no USB 2.0 ports)
  3. Restarted a dozen times
  4. Installed the Mega drivers manually

I have an Arduino Uno, Nano, and Leonardo that I routinely program using this laptop so I’m really stumped at what the issue is here. Does anyone have any other suggestions?

Thank you!