Arduino mega USB port not working


So Im working on a project which includes using a ultrasonic sensor and a servo. Ive seen loads of tutorials online when people use only used the barrel jack, so I did the same :o . that's when the problem occurred, it didn't work so I tried plugging in the usb, that's when I heard a pop from the Arduino, I got scared and unplugged everything. I then plug it back in to see if it worked, it turned on but Arduino cc couldn't recognise the Arduino. I also tried plugging every thing back in, the NO light seemed to be very dimmed. I don't really know what happened, so that's why I'm asking for you're help.

You mean the ON light.

If you hear a pop from the board, you damaged it bad. Not sure exactly what you did wrong, but something went very wrong.

It's dead. Buy a new one.

Yes I mean the ON light:) Which Arduino would you recommend buying?

I'm partial to the Arduino Nano because the small size and on-grid pins makes it easy to use for prototyping as well as for incorporating into finished projects. The lower cost compated to the Mega means that it won't be so painful if you accidentally destroy one.

An even more economical solution is the Pro Mini. Since the Pro Mini doesn't have an on-board USB to TTL serial adapter, you use a separate one that you could share between multiple Pro Minis. In some cases, you might find that a damaging incident destroys either the Pro Mini or the USB adapter, but not both, saving money on the replacement costs.

Of course neither of those boards have the memory and quantity of pins that the Mega does, so it really depends on your application. I think very few people actually need as much memory and pins as the Mega provides, but the ATmega328P boards can be a bit limiting sometimes.