arduino mega, xbee shield 2.0 and xbee -> cannot make it work

Hi all,

This shield is driving me mad ! I’ve tried many and many solutions found on the internet but nothing works. Let me explain :
I have 2 arduino mega, 2 xbee shield V2.0 and 2 xbee S1 xb24 model.
I have plugged jumper between rx and digital for pin 11
I have plugged jumper between Tx and digital for pin 10

I’ve tried a little program that use SoftwareSerial and just read data from xbee.

#include <SoftwareSerial.h>
SoftwareSerial xBeeSerial = SoftwareSerial(11, 10);

int incomingByte;

void setup() {
  Serial.begin(9600);           
  xBeeSerial.begin(9600);
}

void loop() {
  Serial.print(".");
  if(xBeeSerial.available()) {
    Serial.println("xbee ready");
    incomingByte = xBeeSerial.read();
    Serial.println(incomingByte);
  }
  delay(1000);
}

Here are two pics of my configuration


I don’t know what’s wrong with that but it never print “xbee ready” (so xbeeserial is never available).
I’ve tried to reset xbee shield with the little button but nothing changes.
I’ve tried to use x-ctu but it never let me use the shield (it always ask me to press reset button but nothing else).
I’ve tried both arduino and xbee shields (in case of a bricked one) but same thing happens → nothing.

Is there an error in my code ? my jumper configuration ?
Do you have an idea of what’s going wrong please ?

Regards
Steeve

What it is your configuration of your Xbee wireless? You have to set up the address of the TX Xbee and the RX Xbee, the Personal Id for the network on the Xbees. It looks like that you are trying to set it up right out of the box. Also, the default ports on an Arduino are 1 and 0, I would use those to start, that means you need to set your jumpers on the shield to that effect.

I just had the wireless breakthrough yesterday and I used the code from the XBee 802.15.4 modules and Communication | Physical Pixel pages to use code that I know works. Good Luck!