Arduino Mega2560 + GPS ublox LEA-5H

Hi,

I'm trying to develop a software to manage the GPS, but it never return any value. I'm using an arduino mega2560 plus a GPS shield with uBlox LEA5-H.

It seems like it was a halt when microcontroller try to access to GPS address (0x42).

I tried reading directly from wire ports, and then using a library, but it doesn't matters, it didn't work yet.

Could someone help me about??

PD: I have attached the sketchs I used for, also the library.

GPS_without_library.zip (1.39 KB)

GPS_UBLOX.zip (7.78 KB)

Hi again,

I tried it with Arduino UNO without library code, and it works fine!!

So I think the problem is serial, there has to be a way to connect GPS with Arduino MEGA that works correctly.

I'll try to find it.

Regards.

I can connect to my GPS module via serial port.
Different setup but it does work. You can see it here:
http://www.seti.net/Cosmic%20Rays/Engineering/engineering.htm

Regards.... Jim

Hello, I have the same problem with my Arduino Mega ADK.

I can't access the link above, so I have to ask you about reuploading the link with setup. Also I'd like to learn more how you've connected LEA-5H and Arduino. What position were the jumpers setting in? Did the LEA-5H have other connections with Arduino? How can LEA-5H interface with Arduino by I2C, if the board LEA-5H is NOT connected directly to the SDA and SCL pins.

Thanks