Arduino Mega2560 uknown usb device

Hi guys, so I've looking for a solution but nothing works, every post of this kind is around the same problem when the device is listed under "Other devices > Unknown device".

I have been working in this device without problem under Win7 for the last couple of months, but suddenly is not working. And currently It's wired to a 16x2 LCD and is performing the sketch, a simple clock.

But since is not been recognized I can't upload anything else.

Now the problem, my device is listed under "Universal Serial Bus controllers > Unknown device" as you can see in the screenshot

I've tried to update the driver, but no luck, maybe I'm missing something, something I'm not seeing?

Neither in the manufactures menu is an option for ports.

Selecting the driver is not working as it doesn't recognize it as the correct driver.

At this point I'm not sure what else I can do.

  • Used different USB cables, just to avoid a bad defective cable
  • Performed a loop-back test following this, no luck as is not in the COM list
  • Used another computer and two different OS, Win XP and Win7
  • I'm not using a USB hub or USB 3.0

And I can't find a similar problem to mine, hope you can help me, thanks.

Do you have anything else plugged into the USB 2 (not USB3) ports on the machine - are they working OK ?

have you tried plugging the Arduino into the USB 3 port ?

Is this an R3 board ?



Nothing else is plugged but my mouse, I've connected my nano v3 and is working using the same cables.

It's a R1 my board, I'm thinking the USB chip got fried, but I don't know how.

Thanks, Alex.

try checking the usb cable connection on the motherboard. also try a different usb port.


Hi even I'm confronting the same error..

Did you find any solutions to this error?