Arduino micro stopped working.

Hi, here's what's happening. When I connect my micro to computer it shows up, but after a while it disappears, and does not show again (as a different COM) as it used to. I've checked on other usb ports and computers. What can be the cause of this behaviour? Something with bootloader?

It also stop running last program, that i uploaded on it. If it helps it also gets pretty hot (the chip and pins) when i try to run it off 9dc adapter.

How long until is disappears?

Other than the 9v source, what else is connected?

About 6 s, then it disappears and the onboard led stops blinking (on led is still on)

Midi socket, mono 3,5 jack socket, some switches (toggle and a footswitch, total of 5 pullup_input), RGB led (common catode), 10kpot and everything is in aluminum enclosure. Both sockets had nothing pluged into them when it stopped working.

Before it stopped working, I was just tweeking part of the program which changed functions used with switches. It worked on usb but when i pluged 9v dc i had some issues. Last one of them was led turning on randomly and some tx, rx blinking.

OK, case solved! Unsoldering everything and holding reset button till upload starts worked. I uploaded blink, and now computer sees arduino on both temporary and permanent COM.