Arduino Micro with LiPo issues!

so my current circuit draws about 40-50mA of current max while in operation. I need to power it with a battery and initially thought I could use coin cell batteries. That did not work as they seem to drop voltage really quick. Next I tried some small LiPos (3.7V 110mAh) and they don't work either? I've connected the new Lipo to a TP4056 board and connected that to a mt3608 boost module to output 6V. The batteries power the Arduino for a second and then instantly the voltage between vin and gnd drop to 0.15. When testing with other batteries, this issue doesn't happen. By this I mean I've tried other bigger Lipos (3.7V 2000mAh - 4000maH). does anyone have an explanation for this? thanks!

Just to confirm, you have one of these Arduino Micro boards?

Which pins have you connected the battery to?

The Arduino specs suggest that it runs off either 5V (applied to the 5V pin) or 7-9V applied to the Vin pin.

yes, i have that exact board and im powering it from the vin and gnd pins. i have tried to increase the voltage to 7 volts but with the smaller Lipo it still doesnt work

That all sounds a rather round about way of powering the board.

So you have 3.7V LiPo battery -> LiPo charger (TP4056) -> Boost Module (MT3608) -> Vin - hopefully generating around 7V?

I think you can wind down the MT3608 to 5V and connect its output to the 5V pin. Hopefully somebody with more knowledge than me on power will chip in shortly and point you in the right direction.

Not strictly in spec, but have you tried just powering it directly from the 3.7 V LiPo?

A (Pro) Micro fitted with an 8 MHz crystal and possibly a modified bootloader would - like the 8 MHz version of the Pro Mini - function perfectly at 3.7 V.