Arduino MKR is not recognized by USB

Hello all,

I bought several MKRs for my project, both MKR1000 and MKR1400GSM. Sometimes happen that Arduino is not recognized by USB. Double click on reset switch helped.
Now, though, I have MKR1400 which is not responding. It is not recognized by Device manager (using W10 Prof), I can see error 43 "A request for the USB device descriptor failed."
So, no hardware ID is read.
After power-up, the charge LED quickly blinks for a short time. Next, LED on pin 6 lights and stay on.

Other MKR1400 device is normally visible, using the same cable and the same USB port.

I hereby confirm that:

  • first of all, I read tons of topics on this forum (and other forums, as well).
  • Removed foam
  • Assured that USB port is not 3.0
  • Tried several cables
  • Tried another PC (with W7)
  • Double-clicked reset switch
  • I am an experienced guy, not a newbie.

I liked MKR design at first, but now I am disappointed. Seems to me that original Arduino became less reliable than Chinese clones :frowning:

So, please, can somebody help me? Or, at least, suggest something useful?

Please don't suggest me the obvious things I already tried, as listed above.

Milos

Hello forum admin I also have this problem please help me as well


Best washing machine in india

SOLVED.

Apparently, downloading my sketch, the bootloader was damaged. How can be it possible, I cannot say.
Somebody from Arduino team should tell us.

I soldered a male header to pads on the bottom of MKR. Then, I was able to erase the chip memory and flash there bootloader again using J-link adapter.

Then, Arduino appeared in Device Manager again. I downloaded Blink example - ok, blinks.

Hope this will be helpful.

Milos