Arduino MKR WiFi 1010 firmware update failing


I'm on the first steps of Opla IoT Kit. When configuring the IoT Cloud, it is not possible to update the MKR Wifi 1010 firmware. It keeps displaying the following message:

 We were not able to update the firmware
 Something went wrong!
 Please try to:

Restart the Create Agent on the computer.
Reconnect the device to the computer and make sure the power LED lights up.

I had already tried to restart the agent, to used mozilla and chrome but it is still not working.

I'm using MacOs M1 Big Sur 11.3.1.

What steps could fix this issue?



@betesp, your topic has been moved to a more suitable section of the forum.

Hi, I was able to upload the Sketch. I upgraded the firmware to the Arduino MKR through the IDE.

This issue can be marked as resolved.


Hi There,
I had similar issues, updated firmware via the hourly builds but IOT would still try and update to a later version where things would fail again.
Installed latest 'create agent' and turned off my antivirus / firewall. Firmware then successfully updated via Arduino IOT page.


1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.