Arduino MKR Wifi 1010 not configuring

I am pretty new to Arduino, as I am configuring my first one. I was trying to connect the IoT MKR Wifi 1010 Arduino to my PC, and it is failing to connect. My computer recognizes the board, and goes through the naming process. However, once I hit "next", it tries to configure and then says

"We were not able to configure your device

Executing command: exit status 1

Please try to:

  • Restart the Create Agent on the computer.
  • Reconnect the device to the computer and make sure the power LED lights up."

I have tried both of the things it recommends, and neither have worked. The PWR and ON lights are green, and no other lights are active. The MKR Wifi 1010 is plugged into the IoT carrier, and the screen is lit up but not displaying anything. Is there anything I am doing wrong or am not doing, that could fix this? Thank you.

Picture:

  1. Try a new USB cable make sure its data capable and not a charging cable

  2. Close any other IDE's eg. Web editor or Arduino IDE

  3. Refresh your browser

  4. What browser are you using? Chrome or Firefox would be ideal.

  5. Disable any firewall or antivirus that could potentially block the installation

    • Blocked Pop-up window
    • Sometimes the agent installation can be blocked by the firewall or antivirus software; in the latter case, you can try to add the agent to your Antivirus whitelist.
  6. Maker sure you have launch the create agent application

  • Search for the App and open it
  1. Before configuring a board, press the reset button twice in quick succession while the board is connected, to reset the bootloader
  2. Click the Add Device button.

@bluefury6 Ensure that you use a good quality data USB cable capable of 480Mbps and do not use a USB hub or USB 3.0 port.
Secondly, make sure you have the latest Arduino Create Agent installed (Arduino Cloud - Getting started) and it is running.

So I checked, and all of the USB ports on the computer I was using were 3.0. However, I have another computer which had a USB 2.0 port, which I used. I also reinstalled the create agent on that computer. whatever it was, my Arduino is working now.