Arduino MKR1000 stopped showing me the port connexion [SOLVED]


I was basically trying to connect an Arduino MKR1000 to the internet to be able to record online data (Cayenne Cloud). At first, the connexion between computer and Arduino went without any problems. And I was even taking measurements from a temperature sensor so everything ok here.

But after that, when I tried it again after a break, it somehow disconnected and I am not able anymore to see a port connexion while trying to connect computer and Arduino (in the Arduino app I mean). I tried through "Device Manager" to update and even reinstall the device (my computer does not recognize the Arduino anymore), but I just get the message that the device is already fully updated. I got stuck here as I found no one on any forum with the same problem.

Did you experience a similar problem to help me out? Or any guess on what could be causing it?. I will for sure gladly answer any questions referred to it.

Thank you in advance,

simple solutions are sometimes the best ones. So in my case, after some more internet search, I found that the MKR1000 has a small white button in the middle of it. Tap it twice and you will finally see that missing port :slight_smile:

What do you mean by "APP" exactly

The regular desktop IDE or the windows 10 APP or the CREATE ONLINE EDITOR ?

If it is the win 10 APP then remove it and try the regular IDE as there have been issues mentioned with the APP.

Also as it is an MKR have you tried to quickly double tap the reset button to put it into bootloader mode (that will show a new COM port)