Arduino MKR1010

Good morning.
I recently bought an arduino mkr1010.
After installing the SAMD card manager, the wifinina and arduino_blue libraries, i still cannot read the card. The computer gives me the error that I attach in the photo.

[The last connected device does not work and it has not been recognized.]

Could it be a card problem?
What should I do?

Thank you very much for helping me.

Posting tips.

  • Always list the version of the IDE you are using and the board version if applicable.
  • How to insert an image into your post. ( Thanks Robin2 )
  • Add your sketch where applicable but please use CODE TAGS ( </> )
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can

Moved your topic to it’s current location as it is more suitable.

Could you take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

Bob.

The ide version is 1.8.10 but I also tried 1.8.9.

For the images I was unable to attach them as described in the guide.
I used google drive.
Please copy the link and open it in google.

There is no code because I can't detect the card.

The card is arduino MKR1010.
Thank you for helping me.

These sections are primarily English.
There are others available if you would like me to move you there.
Mentioning this as one of your pics seems to be in a different language.

Bob.

Yes,
my image is in Italian but I also wrote the correct translation under the first comment.

[The last connected device does not work and it has not been recognized.]

And you ruled out USB 3.0 issues ?
Also what OS exactly please ?

Sorry so many Q. just trying to rule some things out.

Bob.

The OS is windows 10.
For the usb i don't have any issues. It works with arduino uno, mega and nano.

I thought it might be a driver problem but also after download the samd the card still does not work.

I don't know if the card can be broken.

No problem for the Q. I know the questions are to better understand the problem.

Thank u for the help.

Some boards are more particular about USB ports than others that's why I wanted to check you had tried USB 2.0.

The card can be broken with incorrect voltage levels but if you have only had it connected to USB and no sensors etc then it should not be broken.

Windows 10 has thrown a lot of problems itself recently along with IDE 1.8.10
Windows 10 driver enforcement can also cause its own issues.

There have been a couple of reports recently of a board working with the correct driver then not working and putting out driver issues at the very next upload. I don't think the issue has been fully sorted out or identified as such.

My own work around is to have FULL administrator privileges and driver enforcement turned OFF for those types of problem.
And whilst installing with those off it can also be useful to turn off any additional security such as antivirus or similar.

Good morning.

So I'm using a usb 2.0 port.

I have also full administrator privileges.

I turned off the Signed Driver Enforcement and the Windows antivirus and I tried to install the SAMD card manager but I still can't read the card....

Do you have any other advice or attempts that I can do?

Thank you for the help.