Arduino nano 33 BLE UART communication issue

I am trying to just do a simple proof of sending UART communication to and from the NANO to another microcontroller (Particle Photon) and i am not seeing any results.
Currently i have my particle setup to send a "1" every second

//Particle Photon
void setup() {
    Serial.begin(9600);
    Serial1.begin(9600);
}
void loop() {
  Serial1.print("1");
  delay(1000);
}

I have my NANO setup to receive this and toggle the built in LED

//Arduino Nano 33 BLE
void setup() {
  pinMode(LED_BUILTIN,OUTPUT);
  Serial.begin(9600);
}

void loop() {
  if (Serial.available() > 0) {
    digitalWrite(LED_BUILTIN,!digitalRead(LED_BUILTIN));
  }
}

Seems pretty straight forward but I get no blinking on the NANO.
I have
RX(PHOTON) -> TX(NANO):PIN 1
TX(PHOTON) -> RX(NANO):PIN 2
I have the boards powered up with their respective onboard USB and I have the grounds for each board connected.
I have read that the nano 33 ble only has one serial connection so if I have it plugged into my computer and try to communicate with it through UART I might fail.
NANO is plugged into a 5v USB wall socket.
PHOTON is plugged into a computer.

Now I'm not sure if this is a valid test but i did meter the TX wire from the PHOTON and it seems to be dropping some voltage every second. Maybe this means it is sending something.

When i do have the NANO plugged into the computer with no PHOTON hooked up i can use the serial monitor to send a message and the NANO is able to print that message to a terminal. Not sure if that proves anything but at least that works.

I am really just trying to do a simple communication from one microcontroller to another and i cant seem to figure this out. Outside of a bad breadboard/wires/hardware is there any reason this shouldn't work?

EDIT:
I also tried to use this example and got nothing
https://forum.arduino.cc/?topic=660121#msg4447450

The Arduino Nano 33 BLE has native USB and Serial is used for a virtual COM over USB.

To use the hardware UART you need to use Serial1.

You are a genius, I know I tried serial1 at some point but I don't think I ever got back around to trying it again. Thank you so much!