Arduino nano 33 iot not recognised windows 11

hello,

I have three arduino nano 33 iot boards and none of them are being recognised on cloud iot. I bought them direct from the arduino store and have tried resetting them. I have also tired using different leads and it is recognising my other boards but doesn't seem to recognise the nano 33's.

Every time I get the same message:

We could not find any Arduino device
Please try to:

  • Restart the Create Agent on the computer.
  • Reconnect the device to the computer with another USB cable and make sure the power LED lights up.
  • Reset your device

Any ideas?

My first guess would be the USB cable.
I had the same error with my IoT 33 (ok, it was on Windows 10), but the problem is that I was using a charging only USB cable (JBL GO 2). This kind of cable doesn´t have the data transmission part. Thus, the board won´t talk to your PC.

--> Try another USB cable

I have tried this with no luck!!
Any other ideas?? If not I'm lost!

Are the boards recognised by your PC?

I have another guess, but not sure it will solve the problem.

Those boards need to have the WIFININA firmware updated to the latest version in order to operate properly. Upload the firmware checker sketch to your boards to see if they have the latest version. If not, upload the updater sketch e run the updater app.

You can get more info on this process at https://www.arduino.cc/en/Tutorial/WiFiNINA-FirmwareUpdater