Arduino nano and oled display 128x64 not working

The following code works perfectly on my arduino uno r3 i tried to make it work on my arduino nano(Chinese clone version) and it didn’t work. I’ve tried the new and old boot-loader and it still didn’t work.
I have also uploaded the blink example code onto my nano with the built on led, and that works so i know it is definitely processing the code.
P.S I have definitely wired it correctly and the type of display i am using is the oled 128x64 i2c.

The URL for the display.
(https://www.amazon.co.uk/DSD-TECH-Screen-Support-Arduino/dp/B07D56L5S4/ref=sr_1_10?keywords=arduino+oled&qid=1556914930&s=gateway&sr=8-10)

Photo of wiring

Can anyone help me please?

#include <Adafruit_SSD1306.h>// allow config of oled display
#include <Adafruit_GFX.h>// gives gfx for oled display
#include <Wire.h> // alows i2c com

#define OLED_RESET 4
#define SCREEN_WIDTH 128
#define SCREEN_HEIGHT 64

Adafruit_SSD1306 display(SCREEN_WIDTH, SCREEN_HEIGHT, &Wire, OLED_RESET);

void setup()
{
  display.begin(SSD1306_SWITCHCAPVCC, 0x3C);
  display.clearDisplay();
  display.setTextColor(WHITE);  
  display.setTextSize(2);
  display.setCursor(25,5);
  display.print("Starting ...");
  display.display();
}

void loop()
{
}

could you pls provide us the exact model of your display?
also, don't be so sure about your wirings...
if possible,share the wirings too
that would help

**** IMPORTANT ****

To the forum moderator and user "ROUGH", I am really sorry, I am new to this forum and using forums and I accidentally reported your post, please ignore that report, apologies again.

ROUGH
I've reviewed your request and updated the topic.
If there is any further information i can provide please ask, thank you.

If it works with a Uno it should work with the Nano.

Just check the jumper wires are not broken.
Move the 4 I2C wires from breadboard from Nano to Uno.

David.